$re = '/^(?P<type>([a-z]*))((?P<dev>[0-9]+).)?((?P<module>[0-9]+).)?((?P<port>[0-9]+))$/m';
$str = 'tengigabitethernet1-24
gigabitethernet0/0-1
1/1
g1/1/1
1/1/1
1.1
1-1
1_1
1.1.1
eth0.10
eno3p4
enp4s0f0
vmbr1.10
britge0.50';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);