import Foundation
let pattern = #"^(?P<type>([a-z]*))((?P<dev>[0-9]+).)?((?P<module>[0-9]+).)?((?P<port>[0-9]+))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
tengigabitethernet1-24
gigabitethernet0/0-1
1/1
g1/1/1
1/1/1
1.1
1-1
1_1
1.1.1
eth0.10
eno3p4
enp4s0f0
vmbr1.10
britge0.50
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)