const regex = /^(?P<type>([a-z]*))((?P<dev>[0-9]+).)?((?P<module>[0-9]+).)?((?P<port>[0-9]+))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<type>([a-z]*))((?P<dev>[0-9]+).)?((?P<module>[0-9]+).)?((?P<port>[0-9]+))$', 'gm')
const str = `tengigabitethernet1-24
gigabitethernet0/0-1
1/1
g1/1/1
1/1/1
1.1
1-1
1_1
1.1.1
eth0.10
eno3p4
enp4s0f0
vmbr1.10
britge0.50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}