const regex = /\d{3}(?!\d?$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{3}(?!\\d?$)', 'gm')
const str = `9871234567`;
const subst = `xxx-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);