$re = '/\d{3}(?!\d?$)/m';
$str = '9871234567';
$subst = "xxx-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;