use strict;
my $str = '9871234567';
my $regex = qr/\d{3}(?!\d?$)/mp;
my $subst = 'xxx-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";