import Foundation
let pattern = #"\d{3}(?!\d?$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"9871234567"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"xxx-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)