using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://\S*?(?=(?<!=)https?://|$)";
string substitution = @"\n";
string input = @"http://foo.barhttps://foo.bazhttp://foo.bar?url=http://foo.baz
http://foo.bar?url=http://foo.baz?foo=bar&baz=quxhttp://";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}