re = /https?:\/\/\S*?(?=(?<!=)https?:\/\/|$)/m
str = 'http://foo.barhttps://foo.bazhttp://foo.bar?url=http://foo.baz
http://foo.bar?url=http://foo.baz?foo=bar&baz=quxhttp://'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result