$re = '/https?://\S*?(?=(?<!=)https?://|$)/m';
$str = 'http://foo.barhttps://foo.bazhttp://foo.bar?url=http://foo.baz
http://foo.bar?url=http://foo.baz?foo=bar&baz=quxhttp://';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;