import Foundation
let pattern = #"https?://\S*?(?=(?<!=)https?://|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://foo.barhttps://foo.bazhttp://foo.bar?url=http://foo.baz
http://foo.bar?url=http://foo.baz?foo=bar&baz=quxhttp://
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)