# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^.{10})-//gm;t' <<< "YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS"