$re = '/(?<=^.{10})-/m';
$str = 'YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;