#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^.{10})-"
Local $sString = "YYYY-MM-DD-HH-MM-SS" & @CRLF & _
"YYYY-MM-DD-HH-MM-SS" & @CRLF & _
"YYYY-MM-DD-HH-MM-SS" & @CRLF & _
"YYYY-MM-DD-HH-MM-SS" & @CRLF & _
"YYYY-MM-DD-HH-MM-SS" & @CRLF & _
"YYYY-MM-DD-HH-MM-SS"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)