use strict;
my $str = 'YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS
YYYY-MM-DD-HH-MM-SS';
my $regex = qr/(?<=^.{10})-/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";