const regex = new RegExp('[\\x{1F000}-\\x{1FFFF}|\\x{20a0}-\\x{32ff}|\\x{fe4e5}-\\x{fe4ee}|\\x{200D}]+', 'gm')
const str = `🙌🏻
1F64C 1F3FC sd
😈
🏿
👩🏾🤝👨🏿
👩🏾🤝👨🏿
👨👩👦`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}