// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\x{1F000}-\x{1FFFF}|\x{20a0}-\x{32ff}|\x{fe4e5}-\x{fe4ee}|\x{200D}]+").unwrap();
let string = "🙌🏻
1F64C 1F3FC sd
😈
🏿
👩🏾🤝👨🏿
👩🏾🤝👨🏿
👨👩👦";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}