import re
regex = re.compile(r"[\x{1F000}-\x{1FFFF}|\x{20a0}-\x{32ff}|\x{fe4e5}-\x{fe4ee}|\x{200D}]+", flags=re.MULTILINE)
test_str = ("🙌🏻\n"
"1F64C 1F3FC sd\n"
"😈\n"
"🏿\n"
"👩🏾🤝👨🏿\n"
"👩🏾🤝👨🏿\n"
"👨👩👦")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")