using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\*?|\([^()]+\)|""[^""]+""";
string input = @"""sonoma wildfires""
sonoma and (wild* or stratus or kincade)
sonoma and (wild or ""stratus kincade"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}