import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\*?|\\([^()]+\\)|\"[^\"]+\"";
final String string = "\"sonoma wildfires\"\n"
+ "sonoma and (wild* or stratus or kincade)\n"
+ "sonoma and (wild or \"stratus kincade\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}