re = /\w+\*?|\([^()]+\)|"[^"]+"/m
str = '"sonoma wildfires"
sonoma and (wild* or stratus or kincade)
sonoma and (wild or "stratus kincade")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end