package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+\*?|\([^()]+\)|"[^"]+"`)
var str = `"sonoma wildfires"
sonoma and (wild* or stratus or kincade)
sonoma and (wild or "stratus kincade")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}