#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[A-Z0-9 -]+$"
Local $sString = "Andy P" & @CRLF & _
"Fail{}" & @CRLF & _
"123.Test" & @CRLF & _
"Big Daddy" & @CRLF & _
"Essential." & @CRLF & _
"`sfsdfsdf" & @CRLF & _
"{fsdf}" & @CRLF & _
"asfdasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")