import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z0-9 -]+$";
final String string = "Andy P\n"
+ "Fail{}\n"
+ "123.Test\n"
+ "Big Daddy\n"
+ "Essential.\n"
+ "`sfsdfsdf\n"
+ "{fsdf}\n"
+ "asfdasd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}