package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[A-Z0-9 -]+$`)
var str = `Andy P
Fail{}
123.Test
Big Daddy
Essential.
\`sfsdfsdf
{fsdf}
asfdasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}