re = /^[A-Z0-9 -]+$/im
str = 'Andy P
Fail{}
123.Test
Big Daddy
Essential.
`sfsdfsdf
{fsdf}
asfdasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end