import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\/\\/.*+$)\\R?((?:(?!\\/\\/\\/).*+\\R)*?^.*+$)\\R(^-?\\d+$)";
final String string = "/// woodland-creature9\n"
+ "ipsum lorem and a blah blah blah\n"
+ "Edit: LOL 😂\n"
+ "106\n"
+ "/// Bibber77\n"
+ "ya you got it.\n"
+ "lots of blah blah blah. we like to write gibberish.\n"
+ "-1\n"
+ "/// Bummer_Pro_68\n"
+ "there's no shortage of gibberish to write\n"
+ "-6\n"
+ "/// woodland-creature9\n"
+ "why not why so what does, it all mean, i dont know (aesthetics)\n"
+ "13\n"
+ "/// PrincipalRR\n"
+ "/// PrincipalRR\n"
+ "/// xvoid9710\n"
+ "beware scary woodland creatures\n"
+ "13";
final String subst = "$1 [$3] = $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}