re = /(\/\/\/.*+$)\R?((?:(?!\/\/\/).*+\R)*?^.*+$)\R(^-?\d+$)/m
str = '/// woodland-creature9
ipsum lorem and a blah blah blah
Edit: LOL 😂
106
/// Bibber77
ya you got it.
lots of blah blah blah. we like to write gibberish.
-1
/// Bummer_Pro_68
there\'s no shortage of gibberish to write
-6
/// woodland-creature9
why not why so what does, it all mean, i dont know (aesthetics)
13
/// PrincipalRR
/// PrincipalRR
/// xvoid9710
beware scary woodland creatures
13'
subst = '$1 [$3] = $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result