const regex = /(\/\/\/.*+$)\R?((?:(?!\/\/\/).*+\R)*?^.*+$)\R(^-?\d+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\\/\\\/.*+$)\\R?((?:(?!\\\/\\\/\\\/).*+\\R)*?^.*+$)\\R(^-?\\d+$)', 'gm')
const str = `/// woodland-creature9
ipsum lorem and a blah blah blah
Edit: LOL 😂
106
/// Bibber77
ya you got it.
lots of blah blah blah. we like to write gibberish.
-1
/// Bummer_Pro_68
there's no shortage of gibberish to write
-6
/// woodland-creature9
why not why so what does, it all mean, i dont know (aesthetics)
13
/// PrincipalRR
/// PrincipalRR
/// xvoid9710
beware scary woodland creatures
13`;
const subst = `$1 [$3] = $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);