# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/\/\/.*+$)\R?((?:(?!\/\/\/).*+\R)*?^.*+$)\R(^-?\d+$)"
test_str = ("/// woodland-creature9\n"
"ipsum lorem and a blah blah blah\n"
"Edit: LOL 😂\n"
"106\n"
"/// Bibber77\n"
"ya you got it.\n"
"lots of blah blah blah. we like to write gibberish.\n"
"-1\n"
"/// Bummer_Pro_68\n"
"there's no shortage of gibberish to write\n"
"-6\n"
"/// woodland-creature9\n"
"why not why so what does, it all mean, i dont know (aesthetics)\n"
"13\n"
"/// PrincipalRR\n"
"/// PrincipalRR\n"
"/// xvoid9710\n"
"beware scary woodland creatures\n"
"13")
subst = "$1 [$3] = $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.