#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(word1|word2|word3)).*?(?!\1)((?1)).*?(?!\1)(?!\2)((?1))"
Local $sString = "a word3 word3 word2 word 2 word1 word2 word1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")