const regex = /(?=(word1|word2|word3)).*?(?!\1)((?1)).*?(?!\1)(?!\2)((?1))/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(word1|word2|word3)).*?(?!\\1)((?1)).*?(?!\\1)(?!\\2)((?1))', 'm')
const str = `a word3 word3 word2 word 2 word1 word2 word1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}