use strict;
my $str = 'a word3 word3 word2 word 2 word1 word2 word1';
my $regex = qr/(?=(word1|word2|word3)).*?(?!\1)((?1)).*?(?!\1)(?!\2)((?1))/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}