#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\w+\.(png|jpeg|gif|jpg))\b"
Local $sString = "flower.png is photo" & @CRLF & _
"photo001.png is also image file" & @CRLF & _
"-001bikini.jpg is photo file" & @CRLF & _
"I save file 02beach.gif to computer" & @CRLF & _
"wallpaper.jpeg is also photo" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")