package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\w+\.(png|jpeg|gif|jpg))\b`)
var str = `flower.png is photo
photo001.png is also image file
-001bikini.jpg is photo file
I save file 02beach.gif to computer
wallpaper.jpeg is also photo
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}