import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\w+\\.(png|jpeg|gif|jpg))\\b";
final String string = "flower.png is photo\n"
+ "photo001.png is also image file\n"
+ "-001bikini.jpg is photo file\n"
+ "I save file 02beach.gif to computer\n"
+ "wallpaper.jpeg is also photo\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}