import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<header>[^\\s]+)$(?P<value>^\\t[^\\s]$)*";
final String string = "header1\n"
+ " value1\n"
+ " value2\n"
+ " value3\n"
+ "header2\n"
+ " h2_value1\n"
+ " h2_value2\n"
+ "header4\n"
+ " h2_value1\n"
+ " h2_value2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}