// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<header>[^\s]+)$(?P<value>^\t[^\s]$)*").unwrap();
let string = "header1
value1
value2
value3
header2
h2_value1
h2_value2
header4
h2_value1
h2_value2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}