re = /^(?P<header>[^\s]+)$(?P<value>^\t[^\s]$)*/m
str = 'header1
value1
value2
value3
header2
h2_value1
h2_value2
header4
h2_value1
h2_value2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end