$re = '/^(?P<header>[^\s]+)$(?P<value>^\t[^\s]$)*/m';
$str = 'header1
value1
value2
value3
header2
h2_value1
h2_value2
header4
h2_value1
h2_value2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);