import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\n)(([0-9]+)\\.[\\s\\S]*?)(?=\\n[0-9]+\\.|\\Z)";
final String string = "1. First sentence. \n"
+ "2. Second sentence. \n"
+ "1. Another sentence. \n"
+ "3. Third sentence.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}