re = /(?:^|\n)(([0-9]+)\.[\s\S]*?)(?=\n[0-9]+\.|\Z)/m
str = '1. First sentence.
2. Second sentence.
1. Another sentence.
3. Third sentence.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end