$re = '/(?:^|\n)(([0-9]+)\.[\s\S]*?)(?=\n[0-9]+\.|\Z)/m';
$str = '1. First sentence.
2. Second sentence.
1. Another sentence.
3. Third sentence.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);