const regex = new RegExp('(?:^|\\n)(([0-9]+)\\.[\\s\\S]*?)(?=\\n[0-9]+\\.|\\Z)', 'gm')
const str = `1. First sentence.
2. Second sentence.
1. Another sentence.
3. Third sentence.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}