using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]+[0-9]+";
string input = @"ZXXZX123
If you want to shop in store, use this coupon ZXXZX123 to save $20 off your in-store purchase of $100 or more, or $100 off $500 or more.
what
okay
will
not
match
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}