// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]+[0-9]+").unwrap();
let string = "ZXXZX123
If you want to shop in store, use this coupon ZXXZX123 to save $20 off your in-store purchase of $100 or more, or $100 off $500 or more.
what
okay
will
not
match
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}