$re = '/[A-Z]+[0-9]+/m';
$str = 'ZXXZX123
If you want to shop in store, use this coupon ZXXZX123 to save $20 off your in-store purchase of $100 or more, or $100 off $500 or more.
what
okay
will
not
match
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);