re = /[A-Z]+[0-9]+/m
str = 'ZXXZX123
If you want to shop in store, use this coupon ZXXZX123 to save $20 off your in-store purchase of $100 or more, or $100 off $500 or more.
what
okay
will
not
match
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end