#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^value:\s?([^-\n]+)(?:\s-.*?-\s)?([^-\n]*)(?:\s|$)"
Local $sString = "value: 1.25MG - OM - PO/TUBE - ashaf" & @CRLF & _
"value:2.5 MG - OM - PO/TUBE -test" & @CRLF & _
"value: 18 UNITS(S)" & @CRLF & _
"value: 850 MG - TDS AFTER FOOD - SC (SUBCUTANE..." & @CRLF & _
"value: 75 MG - OM - PO/TUBE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")