const regex = new RegExp('^value:\\s?([^-\\n]+)(?:\\s-.*?-\\s)?([^-\\n]*)(?:\\s|$)', 'gm')
const str = `value: 1.25MG - OM - PO/TUBE - ashaf
value:2.5 MG - OM - PO/TUBE -test
value: 18 UNITS(S)
value: 850 MG - TDS AFTER FOOD - SC (SUBCUTANE...
value: 75 MG - OM - PO/TUBE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}